Ticket #149 (closed defect: fixed)

Opened 2 years ago

Last modified 18 months ago

Correction for libusb-compat's pkg-config file with static linking

Reported by: brad Owned by: stuge
Milestone: libusb-compat 0.1.5 Component: libusb-compat-0.1
Keywords: Cc:
Blocked By: Blocks:

Description

libusb-compat's current pkg-config has a mistake which results in an improper pkg-config file for static linking. The attached patch adds a Requires.private entry
to the pkg-config to correct the static linking.

Attachments

patch-libusb_pc_in (314 bytes) - added by brad 2 years ago.
0001-libusb.pc.in-Add-missing-Requires.private-libusb-1.0.patch (729 bytes) - added by brad 2 years ago.

Download all attachments as: .zip

Change History

Changed 2 years ago by brad

comment:1 Changed 20 months ago by hjelmn

  • Owner set to stuge
  • Status changed from new to assigned

Looks good to me. Peter, please commit this.

comment:2 Changed 19 months ago by hjelmn

  • Milestone set to libusb-compat 0.1.5

comment:3 Changed 18 months ago by hjelmn

  • Resolution set to fixed
  • Status changed from assigned to closed

Closed by release of libusb-compat-0.1.5

Note: See TracTickets for help on using tickets.